Friday 30 October 2009

AIX 32 and 64 bit Dilemma

Software requirement for 64 bit AIX OS

Beside hardware requirement for running 64 bit operating system on IBM POWER systems , the other main requirement is fileset.The bos.64bit is the Base Operating System 64-bit runtime fileset. If bos.64bit is not installed, you do not have the /etc/methods/cfg64 file. Without the /etc/methods/cfg64 file, you will not have the option of enabling or disabling the 64-bit environment via SMIT, which updates the inittab with the load64bit line (simply adding this line does not enable the 64-bit environment).

The command lslpp -l bos.64bit will reveal if this fileset is installed. The
bos.64bit fileset is on the 4.3.x media, however, installing it does not ensure
that you will be able to run 64-bit software.

With the bos.64bit fileset installed on non 64-bit hardware, you should be able
to compile your 64-bit software; however, you will not be able to run 64-bit
programs on your 32-bit hardware.



Hardware required

You must have 64-bit hardware to run 64-bit applications. At AIX levels 4.3.2
and 4.3.3, to determine whether your system has 32-bit or 64-bit hardware
architecture:

Log in as root.
At the command line, enter:
bootinfo -y

This produces the output of either 32 or 64, depending on whether the hardware
architecture is 32-bit or 64-bit.

In addition, if you enter lsattr -El proc0, at any version of AIX, the output of
the command should return the type of processor for your server.

The types of 64-bit processors are as follows:

PowerPC_RS64
PowerPC_RS64 II
PowerPC_RS64 III
PowerPC_Power3
PowerPC_Power3 II



Kernel extensions vs. 64-bit kernel


To determine if the 64-bit kernel extension is loaded, from the command line
enter:

genkex |grep 64

You should see information similar to the following:

149bf58 a3ec /usr/lib/drivers/syscalls64.ext

NOTE: Having the driver extensions, does not mean that the kernel is a 64-bit
kernel. A 64-Bit Kernel became available at 5.1 oslevel.

The driver extensions just allows the 64-bit application to be compiled by a
32-bit kernel. If the 32-bit kernel has a 64-bit processor, the syscalls64.ext
will allow the 64-bit application to execute. Yet at 5.1, a 64-bit kernel and a
64-bit processor has better performance with 64-bit applications.

To truly change the kernel to 64-bit, you need to be at the 5.1 oslevel. The
means to change to a 64-bit kernel are:

From 32-bit to 64-bit:

ln -sf /usr/lib/boot/unix_64 /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
lslv -m hd5
bosboot -ad /dev/ipldevice
shutdown -Fr
bootinfo -K (should now be 64)

To change the kernel back to 32-bit:

From 64-bit to 32-bit:

ln -sf /usr/lib/boot/unix_mp /unix
ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
lslv -m hd5
bosboot -ad /dev/ipldevice
shutdown -Fr
bootinfo -K (should now be 32)


32-bit and 64-bit performance comparisons on IBM POWER systems


To examine the benefits and drawbacks of going from 32-bit to 64-bit mode and
further effects on the system, consult the following, AIX 64-bit Performance in
Focus, which is available at IBM Redbooks.

In most cases, running 32-bit applications on 64-bit hardware is not a problem,
because 64-bit hardware can run both 64-bit and 32-bit software. However, 32-bit
hardware cannot run 64-bit software. To find out if any performance issues exist
for applications that are running on the system, such as Lotus Notes and Oracle,
refer to those application's user guides for their recommended running
environment.

No comments:

Post a Comment

 How to Enable Graphical Mode on Red Hat 7 he recommended way to enable graphical mode on RHEL  V7 is to install first following packages # ...